Cisco Router Configuration Guide 1800 series (Cisco 1801, 1802, 1803, 1811, 1812)
This article will show you how to configure Cisco 1800 series routers (Cisco 1801, 1802, 1803, 1811, 1812) details from Global parameter settings, routing, Interface protocols, and command line access.
This article provides procedures to configure the basic parameters of your Cisco router, including Global parameter settings, Routing, Interface protocols, and command line access. It also describes the default configuration at startup. Note that individual router models may not support all the features described in this tutorial. Features that are not supported by a specific router will be highlighted.
- Instructions for configuring Cisco routers
- Instructions for configuring Bullet M2HP Wifi router
Each section will have an example configuration and the exact steps to take, invite you to follow along.
Main content in Cisco 1800 router configuration
- Router ports
- See the default router configuration
- Information needed to configure the router
- Configure basic parameters
- Configuring Global parameters
- Fast Ethernet LAN Interface configuration
- Configure WAN Interface
- Wireless Interface configuration
- Configure Loopback Interface
- Configure the Command-Line to access the Router
- Configure static routes (static routes)
- Dynamic route configuration (Dynamic Route)
- Configure RIP
- Configure EIGRP
Router ports
The following table lists the supported Interface for each router and their related ports on the device.
Cisco 1801
Fast Ethernet LANs
SWITCH and FE8 – FE5 (top), FE x and FE4 – FE1 (bottom)
Fast Ethernet WANs
FE0
ATM WAN
ADSLoPOTS
Wireless LAN
LEFT, RIGHT / PRIMARY
BRI
ISDN S / T
Cisco 1802
Fast Ethernet LANs
SWITCH and FE8 – FE5 (top), FE x and FE4 – FE1 (bottom)
Fast Ethernet WANs
FE0
ATM WAN
ADSLoISDN
Wireless LAN
LEFT, RIGHT / PRIMARY
BRI
ISDN S / T
Cisco 1803
Fast Ethernet LANs
SWITCH and FE8 – FE5 (top), FE x and FE4 – FE1 (bottom)
Fast Ethernet WANs
FE0
ATM WAN
G.SHDSL
Wireless LAN
LEFT, RIGHT / PRIMARY
BRI
ISDN S / T
Cisco 1811
Fast Ethernet LANs
SWITCH and FE9 – FE6 (top), FE x and FE5 – FE2 (bottom)
Fast Ethernet WANs
FE0 – FE1
Wireless LAN
LEFT, RIGHT / PRIMARY
USB
1–0
V.92
MODEM
Cisco 1812
Fast Ethernet LANs
SWITCH and FE9 – FE6 (top), FE x and FE5 – FE2 (bottom)
Fast Ethernet WANs
FE0 – FE1
Wireless LAN
LEFT, RIGHT / PRIMARY
BRI
ISDN S / T
USB
1–0
See the default router configuration
When you start the Cisco router for the first time, some basic configuration has been done. All LAN and WAN interfaces have been created, the console and VTY ports have been configured, the internal interface for Network Address Translation has been specified. Use the command show running-config to see the initial configuration, as in the example below:
Note: If you cannot see the original configuration and receive an error message No Password Set, you must reset the original password.
Example: Cisco 1812 default configuration at startup
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
mmi polling-interval 60
no auto-configure mmi
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
subnet-zero ip
!
ip cef
!
ip ips po max-events 100
no ftp-server write-enable
!
BRI0 interface
no ip address
shutdown
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface FastEthernet4
no ip address
shutdown
!
interface FastEthernet5
no ip address
shutdown
!
interface FastEthernet6
no ip address
shutdown
!
interface FastEthernet7
no ip address
shutdown
!
interface FastEthernet8
no ip address
shutdown
!
interface FastEthernet9
no ip address
shutdown
!
Vlan1 interface
no ip address
!
classless ip
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end
Information needed to configure the router
You will have to collect some or all of the following information, depending on the case.
If you are establishing an Internet connection, you will need the following information:
- The Client Point-to-Point Protocol (PPP) name is assigned as the login name
- PPP authentication type: Challenge Handshake Authentication Protocol (CHAP) or Password Authentication Protocol (PAP)
- PPP password to access your Internet service provider (ISP) account
- IP address of DNS server and default gateway
If you are establishing a connection to the corporate network , you and the network administrator must create and share the following information for the router's WAN interface:
- PPP authentication type: CHAP or PAP
- PPP client name to access router
- PPP password to access the router
If you are setting up IP routing, you need:
- Create an address map for your IP network
- Determine the IP routing parameter information, including: IP address, PVC. PVC parameters are usually virtual identifiers (VPI), virtual circuit identifiers (VCI) and traffic shaping parameters.
- Determine the amount of PVC that service providers provide you, along with their VPI and VCI. Each PVC decides which type of AAL5 is supported, which can be one of the following:
- AAL5SNAP: This type will have two cases: RFC 1483 routing and RFC 1483 bridge. For RFC 1483 routing, the service provider must provide you with a static IP address. For RFC 1483 bridges, you can use DHCP to get your IP address, or you can get a static IP address from your service provider.
- AAL5MUX PPP: For this type, you need to identify configuration items related to PPP.
If you plan to connect via ADSL or G.SHDSL:
In this case you need to select the appropriate transmission from the provider.
- For ADSL: Ensure that ADSL signal type is DMT (also called ANSI T1.413) or DMT Issue 2.
- For G.SHDSL: Verify whether the G.SHDSL transmission line complies with ITU G.991.2 standard.
Once you have all the information you need, you can fully configure your Cisco router, starting with the tasks in the basic configuration section.
Configure the basic parameters of Cisco routers
Configuring Global parameters
Follow the steps below to configure the Global parameters for your router:
Order
Purpose
Step 1
configure terminal
For example:
Router> enable
Router # configure terminal
Router (config) #
Enter Global configuration mode when using the console port.
If you are connecting to the router using a remote terminal, do the following:
telnet router name or address
Login: login id
Password: *********
Router> enable
Step 2
hostname name
For example:
Router (config) # hostname Router
Router (config) #
Name the router.
Step 3
enable secret password
For example:
Router (config) # enable secret cr1ny5ho
Router (config) #
Specify an encrypted password to prevent unauthorized access to the router.
Step 4
no domain-lookup ip
For example:
Router (config) # no domain-lookup ip router (config) #
Turn off the auto-decompression feature of incorrect input (typo) to IP address.
Fast Ethernet LAN Interface configuration
The Fast Ethernet LAN Interface on your router is automatically configured as part of the default VLAN and therefore they are not configured with individual addresses. Access is provided through VLAN. You can assign interfaces to other VLANs if you want.
Configure WAN Interface
Cisco 1811 and Cisco 1812 routers have two Interface Fast Ethernet for WAN connectivity. Cisco 1801, Cisco 1802 and Cisco 1803 routers have an ATM Interface for WAN connectivity.
Based on the router model you have, configure WAN with one of the following procedures:
WAN configuration Fast Ethernet Interface: This procedure only applies to Cisco 1811 and Cisco 1812 router models. Perform the following steps to configure the Fast Ethernet Interface, starting in Global configuration mode.
Order
Purpose
Step 1
interface type number
For example:
Enter Interface Fast Ethernet WAN configuration mode on the router.
Note: WAN Fast Ethernet ports are numbered 0-1 on Cisco 1800 series routers.
Step 2
ip address ip-address mask
For example:
Set the specified IP address and subnet mask for Interface Fast Ethernet.
Step 3
no shutdown
For example:
Turn on Ethernet Interface, change its status from off to enabled (administratively down to administratively up).
Step 4
exit
For example:
Exit Interface configuration mode and return to Global configuration mode.
Repeat the above steps for other interfaces if you need to.
Configuring Interface WAN ATM: This procedure only applies to Cisco 1801, Cisco 1802 and Cisco 1803 models. Perform the following steps to configure Interface ATM, starting in Global configuration mode:
Order
Purpose
Step 1
For Cisco 1803 only:
controller dsl 0
mode atm
exit
For example:
For routers using G.SHDSL signal, execute these commands. If the router uses ADSL signal then skip.
Step 2
interface type number
For example:
Enter Interface configuration mode.
Step 3
ip address ip-address mask
For example:
Set IP address and subnet mask for Interface.
Step 4
no shutdown
For example:
Enable Interface ATM 0.
Step 5
exit
For example:
Wireless Interface configuration
Wireless Interface allows connecting to the router via a wireless LAN connection. For more information about this wireless configuration, you can consult more on cisco.com. I will try to add more later.
Configure Loopback Interface
The Loopback Interface acts as a placeholder for static IP addresses and provides default routing information. To configure this Interface, follow these steps:
Order
Purpose
Step 1
interface type number
For example:
Enter Interface configuration mode.
Step 2
ip address ip-address mask
For example:
Set the IP address and subnet mask for Loopback Interface.
Step 3
exit
For example:
Exit the Loopback Interface configuration mode and return to Global configuration mode.
Configuration example:
Loopback Interface in this model configuration is used to support Network Address Translation (NAT) on virtual model Interface. This example shows that the Loopback Interface is configured on Interface Fast Ethernet with an IP address of 200,200.100.1/24, acting as a static IP. Loopback Interface points to virtual-template1 with a dynamic IP address.
!
interface loopback 0
ip address 200.200.100.1 255.255.255.0 (static IP address)
ip nat outside
!
interface Virtual-Template1
unnumbered ip loopback0
no ip directed-broadcast
ip nat outside
Confirm configuration:
To confirm that you have correctly configured the Loopback Interface, enter the show interface command, you will see a confirmation result similar to the example below:
Router # show interface loopback 0
Vòng lặp 0 được mở, giao thức dòng được mở
Hardware is Loopback
Internet address is 200.200.100.1/24
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input Never, output never, output hang never
Last clearing của "show interface" counters never
Queuing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 lần kết nối rate 0 bit / sec, 0 packets / sec
5 minute output rate 0 bits / sec, 0 packets / sec
0 packet input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
Another way to confirm Loopback Interface is to ping it:
Router # ping 200.200.100.1
Loại thoát phân vùng cho abort.
Sending 5, 100-byte ICMP Echos to 200.200.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min / avg / max = 1/2/4 ms
Configure the Command-Line to access the Router
Follow the steps below to configure the Command-Line Router access:
Order
Purpose
Step 1
line [ aux | console | tty | vty ] line-number
For example:
Access the command line configuration mode and specify the command line type. This example specifies the console terminal to access.
Step 2
password
password
For example:
Specify a unique password for console terminal.
Step 3
login
For example:
Turn on password checking when logging in to the terminal.
Step 4
exec-timeout minutes [ seconds ]
For example:
Set the time that the EXEC command interpreter waits until the received user information is received. The default is 10 minutes. You can add more seconds if you want.
In this example, the waiting time is 5 minutes 30 seconds. If entering 0 0 means never wait.
Step 5
line [ aux | console | tty | vty ] line-number
For example:
Specify a virtual terminal to access the remote console.
Step 6
password
password
For example:
Set a password for the virtual terminal.
Step 7
login
For example:
Turn on password checking when logging into the virtual terminal.
Step 8
end
For example:
Exit the command line configuration mode and return to Privileged EXEC mode.
Configuration example:
The following sample configuration will show command line access commands. You do not need to enter the commands marked "default". These commands will appear automatically in the configuration file, created when you use the command show running-config .
!
line con 0
exec-timeout 10 0
4youreyesonly password
login
truyền tải không có (mặc định)
stopbits 1 (default)
line vty 0 4
password secret
login
!
Configure static routes (static routes)
Static routes provide fixed routing paths on the network. They are manually configured on the router. If the network topology changes, static routing must be updated to the new routing. Static routes are separate routes, unless they are redistributed by routing protocols. Configuring static routing on Cisco 1800 series routers is optional. Follow the steps below to configure, starting from Global configuration mode:
Order
Purpose
Step 1
ip route prefix mask { ip-address | interface-type interface-number [ ip-address ]}
For example:
Specify static routing for IP packets.
Step 2
end
For example:
Exit static routing configuration mode, enter Privileged EXEC mode.
Configuration example:
In this example, the static route sends all IP packets with the destination IP address of 192.168.1.1 and subnet mask of 255.255.255.0 on Interface Fast Ethernet to IP address 10.10.10.2. Specifically, packets are sent to a configured PVC.
You do not need to enter the commands marked "default". These commands will appear automatically in the configuration file, created when you use the command show running-config .
!
ip classless (default)
ip route 192.168.1.0 255.255.255.0 10.10.10.2!
Confirm configuration:
To confirm if you have configured the static route correctly, enter the show ip route command and find the static route represented by "S". Confirmation results will look like this:
Router # sh o w ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Không đặt được gateway của cuối cùng
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
S * 0.0.0.0/0 isdirectly connected, FastEthernet0
Dynamic route configuration (Dynamic Route)
In dynamic routing, the network protocol adjusts the automatic path, based on network traffic or topology. Dynamic routing changes will be shared with other routers in the network. Cisco routers can use IP routing protocols such as the Routing Information Protocol (RIP) or the Enhanced Interior Gateway Routing Protocol (EIGRP) to generate dynamic routing. You can also configure several routing protocols on your router.
Configure RIP
To configure RIP you do the following, starting from Global configuration mode:
Order
Purpose
Step 1
rip router
For example:
Enter router configuration mode and turn on RIP on the router.
Step 2
2}
For example:
Specify whether to use RIP version 1 or 2.
Step 3
network ip-address
For example:
Specify a list of networks that RIP applies on, using the network addresses of the directly connected networks.
Step 4
no auto-summary
For example:
Turn off the auto-collapse of child routing features to route by network level. This allows subprefix routing information to go through the classful network.
Step 5
end
For example:
Exit router configuration mode, enter Privileged EXEC mode.
Configuration example:
This configuration enables RIP version 2 on IP network 10.0.0.0 and 192.168.1.0. Execute the command show running-config from Privileged EXEC mode to see this configuration.
!
rip router
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
Confirm configuration:
To confirm that you have configured the standard RIP, enter the show ip route command and look for RIP routing that is denoted by "R". You will see confirmation results of this type:
Router # show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Không đặt được gateway của cuối cùng
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
R 3.0.0.0/8 [120/1] via 2.2.2.1, 00:00:02, Ethernet0 / 0
Configure EIGRP
Follow the steps below to configure EIGRP, starting in Global configuration mode:
Order
Purpose
Step 1
eigrp as-number router
For example:
Enter router configuration mode, turn on EIGRP on the router. ASN network numbers identify routing to other EIGRP routers and are used to tag EIGRP information.
Step 2
network ip-address
For example:
Specify a list of networks that EIGRP applies, using the IP addresses of networks directly connected.
Step 3
end
For example:
Exit router configuration mode, enter Privileged EXEC mode.
Configuration example:
In this example, EIGRP is enabled on the network address 192.145.1.0 and 10.10.12.115. The network number that EIGRP is assigned is 109. Execute the show running-config command from Privileged EXEC mode to see this configuration.
!
eigrp router 109
network 192.145.1.0
network 10.10.12.115
!
Confirm configuration:
To confirm that you have configured the EIGRP correctly, enter the show ip route command, and look for the EIGRP routing, denoted by "D". You will see confirmation results similar to the following:
Router # show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Không đặt được gateway của cuối cùng
10.0.0.0/24 is subnetted, 1 subnets
C 10.108.1.0 is directly connected, Loopback0
D 3.0.0.0/8 [90/409600] via 2.2.2.1, 00:00:02, Ethernet0 / 0
These are the basic procedures for configuring the Cisco 1800 router series. Hope the article is useful to you!
You should read it
- Instructions for configuring Cisco routers
- Review the Cisco RV180 VPN router
- How to Configure a Cisco Router
- How to use PuTTY on Cisco routers and switches
- How to change DNS server on the most popular routers
- Cisco 851W or 871W configuration: IOS standard
- Warning: Detecting more than 1000 Cisco router and switch devices in Vietnam has a serious security error
- Instructions for configuring Bullet M2HP Wifi router
- Solution to store over the network from the router
- Access the home router with admin rights
- How to Set Up a Wireless Router
- List the default password of Cisco routers and switches
Maybe you are interested
How to extract IMG files in Windows 10 10 Best Home Office Work Desks You Can Afford Xiaomi launched the wireless mouse and Miyu keyboard with voice support, priced at 1.3 million Top best wireless mice 2019 7 random inventions but have an extremely important role in the history of human development Logitech launches MX Master 3, the world's best office mouse