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Instructions for fixing common errors in web
browsers

Your browser has a problem? Tired of wrestling with Internet Explorer, Chrome, Firefox, Safari or any other
browser whenever you want to surf the web?

We all use the browser to surf the web everyday, so if there is a serious problem with the browser it will affect
productivity and make you uncomfortable when using it. Here are some common issues you may encounter
while using the web browser and how to fix it.

1. Performance and page loading is slow

While using the browser to see the performance and the page load is slow and the Internet connection is normal,
the reason may be that you are using an older browser version.

To check which browser version is in use, go to Help> About Google Chrome from the Chrome menu; Click
Help> About Firefox in the Firefox menu; Go to Update & Security> Windows Update in Windows Settings
for Edge or tab Updates in Mac App Store for Safari browser.

Another reason can reduce browser performance is extension. Please disable it to see if the problem is fixed.
Choose More tools> Extension in the Chrome menu, Add-on from the Firefox menu, Extensions from the
Edge menu and Preferences> Extensions in the Safari menu.

If the extension is not the cause of the performance problem, it may be because the data cache is corrupted. Refer
to the article Clearing Cache and Cookies on Coc Coc, Chrome, Firefox browsers.
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In Edge, go to Settings and select Choose what to clear in Clear browsing data on the menu. And finally in
Safari, open the menu and select Preferences , Privacy , and Manage Website Data .

In Safari, cache options are hidden - you need to go to the Advanced tab in Preferences , then select Show
Develop menu in the bar menu , open the Develop menu, and select Empty Caches .

2. Propose unwanted URLs

While typing the web address in the address bar, the web browser may suggest unwanted URLs. To delete this
address without deleting the entire web history, you can do this in Chrome and Firefox. In Chrome, type an
address until you get a suggestion, then select it using the arrow keys and press Shift + Delete (or Shift + Fn +
Delete on the Mac). For Firefox, do the same thing as above, but just press Delete (or the spacebar).

1. Instructions on how to delete URLs automatically suggested in Chrome browser

3. The page does not load all

When the page fails to load, it may be due to a problem with the browser, host or Internet connection. Try
refreshing, download the page with another browser on another device if possible to find the cause of the
problem. If this problem occurs with many websites, the possibility is due to the browser if your Internet
connection does not matter.



In this case, clear the local file cache, this will force the program to reload everything on the page. If not, you
can try disabling the extension or uninstall and reinstall the browser.

4. Features Autofill does not work properly

A problem that users often encounter is a problem with Autofill in the browser, such as missing display, no
password saved, etc.

First check if this feature is enabled in browsers. In Chrome, select Settings> Advanced> Auto-fill . In Firefox,
select Options> Privacy & Security> Forms & Passwords . In Edge, select Settings> View advanced>
Autofill or on Safari, select Preferences> AutoFill .

If this feature has been turned on, the reason may be due to corrupted data in the browser log, third-party
extension interfering with this function (especially applications that fill forms and manage passwords password).
In this case delete the cache and check the extension.

1. Instructions to turn off the proposal to save passwords on the Web browser

5. The home page is constantly changing



When the home page is constantly changing without your permission, even if you have reset it many times, this
is a sign that your computer has been infected with malware or adware (adware ). Refer to the article Completely
remove Adware and Spyware on your system.

6. Search for lost URL Bar (or other toolbars)

You may not be able to click somewhere without remembering or for some reason now the URL bar on your
browser has disappeared.

In Internet Explorer, right-click any toolbar and select Address bar . If you're using Internet Explorer 9, you'll
always see the address / search bar, but earlier versions of IE have the option to hide them.

In Firefox, go to View ? Toolbars and check the Navigation Toolbar . Users can also right-click on any
toolbars you see and check the Navigation Toolbar option in the drop-down menu.



In Safari , hold down the Command key ( Ctrl if you're using Windows), the Shift key and the Backslash
button. The URL bar will reappear.

1. Hide the Address Bar in Google Chrome and Chronium

7. Sync Bookmark

Xmarks can sync browser bookmarks between different browsers and computers. Now syncing bookmarks is
simpler thanks to the Xmarks multi-browser sync software (formerly known as FoxMarks ).

1. Download Xmarks for Google Chrome
2. Download Xmarks for Firefox
3. Download Xmarks for Internet Explorer
4. Download Xmarks for Safari

Xmarks saves bookmarks in the cloud, so you can access personal bookmarks from any computer. Even, users
can create multiple bookmark profiles, such as " Home " and " Work ".



To use Xmarks, first download and install it (this tool works with Internet Explorer, Firefox, Chrome, and
Safari). If this is your first time using Xmarks, and you still don't have an account or any bookmarks saved in the
cloud, it will ask you to create an account and sync bookmarks from your computer.

However, if you already have an account and are installing Xmarks on your new computer, this tool will ask if
users want to sync their bookmarks. If you already have bookmarks and want to save them on your computer (as
well as bookmarks from the cloud profile), make sure that Xmarks syncs them all by combining local and on-
premise bookmarks.

1. Sync bookmarks, extensions and other browser data between computers

8. Remember useful shortcuts

Sometimes you want to be a little lazy because you don't like to take your hands off the keyboard and with the
mouse. So why not open a new card with the shortcut? Here are a few shortcuts that can improve your browser
performance.

Card and window management:

1. Ctrl - T: Open a new card

2. Ctrl - N: Open a new window

3. Ctrl - W: Close the current tag

4. F5: Refresh the current page

5. Ctrl - L: Highlight the URL bar

6. Ctrl and +: Zoom in

7. Ctrl and -: Zoom out

8. Ctrl - 0: Return to the default zoom level

Directional:

1. C trl - [ : Return to a certain page
2. Ctrl -] : Move down a page
3. Spacebar : Move the page down
4. Home : Jump on top of the site
5. End : Jump to the bottom of the web page

In addition, users can manage their browser by moving the mouse. To do so, download the free Mouse Gestures
add-on for Internet Explorer, Firefox, Chrome, or Safari.

9. Use the website without having to register a new account

BugMeNot can access websites that require registration. Registering to websites is a problem that makes many
people uncomfortable, even when using a spam email address to minimize advertising. Sometimes you just want
to watch a funny video. Here is a simple way to avoid having to sign up every time you have to access a new
website: Use BugMeNot .



BugMeNot has a valid username and password database for many different websites that require login to access
content inside. You can use BugMeNot in a few different ways.

The easiest method is to visit the BugMeNot website and enter the name of the website you want to log in to.
BugMeNot will introduce a list of usernames and passwords that can be used instead of registration.

If you do not want to have to visit the site every time you need it, download the extension extension for Firefox
or Chrome.

1. Download BugMeNot for FireFox

For other browsers, users can use a bookmarklet (in the toolbar) to instantly receive the BugMeNot login
information. However, BugMeNot does not provide detailed information for paywall sites, so you will inevitably
pay for content when using the service.

10. Block annoying ads

Advertising is not only annoying - it increases the time it takes to load web pages, and they will consume a lot of
data if you are using a paid internet connection according to the download size. Today's browsers often include a
pop-up blocker, so users will not be "bombed" by pop-ups but still see other ads (mostly photos). Fortunately,
removing them is as easy as downloading an ad blocking utility for the browser.

Internet Explorer users should use Simple Adblock and Firefox users can choose Adblock Plus add-ons and
Chrome and Safari users should use Adblock for Chrome and Safari.

1. How to block ads when surfing the web

11. Save an unsuccessful photo

Occasionally, users will encounter a picture on the web that cannot be clicked - sometimes there will be a popup
message displayed, such as " This image is MINE! Don't take it! ". If you still want to save the image to your



computer, you have several ways to do it.

Windows 7 and Vista have a built-in screen capture tool called Snipping Tool. Take a screenshot for that image:
In Windows 7 or Vista, open Snipping Tool ( Start Menu > All Programs > Accessories > Snipping Tool ).
Click the arrow next to the New button and select Rectangular Snip . Use the mouse to drag a rectangle around
the image you want to save.

Once you've snapped the photo, click Save Snip to save it.

If you see something and want to capture it fast (for example, a scene of a video), and don't have time to open
Snipping Tool, just press the Print Screen button on the keyboard. Windows will copy a screenshot of the entire
desktop to the Clipboard. To access the snapshot, open some photo editor, such as Paint, and paste ( Ctrl - V )
the image. Then, cut (if needed) the part you want and save it.

If you're using a Mac computer, press Command - Shift - 4 . The cursor will turn into a cross. Drag this cross
around the photo you want to take. When you release the mouse, the photo is automatically saved on the
desktop. In case you want to capture something quickly, just press Command - Shift - 3 .

Retrieved by source : If you don't want to create a screenshot (maybe because it's too big), you can save the
image from the source code.

Some browsers allow users to directly retrieve any media files attached on a web page. In Internet Explorer, go
to View> Source and find the address of the image in the source code. Copy the address and paste it into the
URL address bar. Now users can right-click to save the image as usual.



In Firefox, go to Tools > Page Info and click on the Media tab. You will see a list of addresses of all photos and
videos on the website you are opening; Clicking on an address will preview the image. Just find the photo you
want to save, click on its address and click Save As .

In Safari, go to View > View Source and find the address of the image in the source code. Copy and paste it into
the URL address bar and press Enter . Then, right-click or Ctrl + click and save the image.

12. Restore a closed manual card

This happens quite often to me: When I want to close a group of cards quickly but click on the X button too
much. Here's how to restore accidentally closed tags.

In Internet Explorer , right-click an active tab and click on the Reopen closed tab . Do this until you find the
card you want to restore.

In Firefox , go to History > Recently Closed Tabs , and find the newly closed tab. Users can also press Ctrl -
Shift - T.

In Chrome , right click on the tab and select Reopen closed tab . Users can also press Ctrl - Shift - T like
Firefox.

In Safari , press Ctrl - Z. This key combination will bring you new closed cards. Just press it until you find the
card you need.

13. Print only what you want



Printing death pages is a bit complicated. Typically, printing a website often costs a lot of ink and paper in
photos, links and advertisements. Fortunately, users can limit what they don't want to print while still getting the
area they want by using a pretty useful bookmarklet called Printliminator.

First, install Printliminator bookmarklet into your browser by dragging it to the bookmark bar.

Printliminator allows you to make the page to be printed more friendly. Now, when you want to print a page,
click Printliminator bookmarklet instead of clicking Print . A small toolbar appears in the left corner of the
browser, providing four options: Remove All Graphics, Apply Print Stylesheet, Send to Printer, and Undo
Last Action.

To remove graphics from the web page, select Remove All Graphics .

To remove some items from the site, such as links and buttons, select Apply Print Stylesheet . Printliminator
will arrange all printable items on sections on the page. To remove a part, simply move the mouse over it and a
red dialog box appears around that part. Click on it to select it and it will disappear.

To fix an error, click the Undo Last Action button. When you have configured the page the way you want and
ready to print it, click the Send to Printer button.

I wish you all success!



See more:

1. Which web browser is best for Windows computers?
2. Instructions to fix basic errors on Google Chrome
3. How to fix 5 common problems on Microsoft Edge browser

 

You finished reading the article "Instructions for fixing common errors in web browsers" edited by the
TipsMake team. We hope this article has provided you with many useful tech tips and tricks. You can search for
similar articles on tips and guides. Thank you for reading and for following us regularly.
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