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This tutorial includes steps to temporarily remove TSR (terminate-and-stay-resident) programs from memory

computer isturned on

and how to prevent them from automatically loading every time the computer starts.

This tutorial includes steps to temporarily remove TSR (terminate-and-stay-resident) programs from memory

and how to prevent them from automatically loading every time the computer starts.

According to the Soha dictionary: TSR is a permanent program, always stored in internal memory, even if it is
not running. Thusit can be started quickly to perform a certain task while other programs are still running. These
programs are often used in non-multitasking operating systems like MS DOS. Permanent or temporary deletion

of TSRswill help to free up computer RAM, improve system performance.

How to handle when TSRs automatically load when booting the
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How to temporarily delete TSR from memory

Below are steps to temporarily remove TSR and programs currently running from memory. Remember that after
restarting the computer, many of these programs will reload. If you want to have these programs permanently
not reload, go to the next section.

Delete TSR in Windows 8 and 10

Right-click the taskbar, select Task Manager. Or press and hold Ctrl + Shift + Esc to directly open Task
Manager. On the Processes tab , select the program you want to end, right-click it and select End Task.

Delete TSR from Windows 2000 to Windows 7

Press and hold Ctrl + Alt + Del , then click Task Manager option . If you are running Windows XP, this key
combination will immediately open Windows Task Manager window. In Task Manager, click the
Applicationstab , select the program you want to end and click the End Task button .
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As you can see in the image above, the Applications window displays only the currently open programs for
users. Other TSRs and Windows Processes are displayed in the Processes tab . Click on the Processes tab , users
will see each process running and the system resources they use are displayed, as shown below.
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Note should only end the programs you know. If you are unsure what the program is, search for the file name for
more information about the process.

Note : Do not End any system processes.

Delete TSR in Windows 95, 98 and M E

Press and hold Ctrl + Alt + Del . Then the Close Program window will appear.



Close Program |
[awatch :I

FPaint32
Syghray
Wastat
Wahwindd
b choal

b dm
Wimere
Irngicon

1| | b

WA RMING: Preszing CTRL+ALT+DEL again will regtart par
computer. “au will loze unzaved information in all programs
that are running.

End Tazk Shut Down Cancel I

Check any listed items except Explorer and Systray, then click the End Task button . Repeat this process until
there are only two running processes. Explorer and Systray.

Some other information:

1. Thereisno way to mark more than one of theseicons.

2. Some of the listed programs may not be removed the first time, please continue until successful.

3. At the end of some of these programs, this This Program is Not responding message may appear. Click
End Task again.

4. Pressing Ctrl + Alt + Del twicein arow will restart the computer.

5. Each deleted item will be returned the next time, when the user restarts the computer (unlessthey are

deleted).

Delete TSR in Windows 3.x
To delete all programs currently running in the background, minimize all open windows including Program

Manager. When each window has been minimized, all currently running applications will be displayed as a small
icon. Open and close each icon except Program Manager.

Permanently disable TSR so that it does not automatically reload

Many TSRs will automatically reload when the computer starts up, if uncomfortable because of that, here are
steps to prevent them from automatically rel oading.

Permanently disable TSR in Microsoft Windows 8 and 10



1. Open Task Manager.
2. Click the Startup tab .
3. Select the program you want to stop automatically loading and click the Disable button .

If it is not possible to determine whether the program is automatically loading by the above, users can find it in
System Registry or use 3rd party software.

Permanently disable TSR in Microsoft Windows XP, Windows Vista and Windows 7

1. Click Start> Programs> Startup .
2. Right-click and delete the file that does not want to start automatically.

If it is impossible to locate the program that is automatically loading, try locating the program in System
Registry or in the msconfig utility.

Permanently disable TSR in Microsoft Windows 2000

1. Click Start> Programs> Startup .
2. Right-click and delete the file that does not want to start automatically.

If it is not possible to locate the program that is automatically loading, try locating the program in System
Registry or in msconfig.

Permanently disable TSR in Microsoft Windows 98 and Windows ME

1. Click Start> Programs> Startup .
2. Right-click and delete the file that does not want to start automatically.

If you cannot locate the program that is automatically loading by following the instructions above, try the
following steps: Locate the program in autoexec.bat, win.ini, System Registry or Windows 98 SE. Windows ME
can disable programs through System Configuration or in msconfig.

Permanently disable TSR in Microsoft Windows 95

1. Click Start> Settings> Taskbar> Start Menu Programs.
2. Click the Start Menu Programs tab.

3. Click the Advanced button .

4. Open the Programs folder .

5. Open the Startup folder and delete the program that does not want to start automatically.



If it is not possible to automatically identify the program, try to find the program in autoexec.bat or win.ini.
Windows 95 and NT users should also check in the System Registry.

Permanently disable TSR in Microsoft Windows NT 4.0

1. Click Start> Settings> Taskbar> Start Menu Programs.

2. Click the Start Menu Programs tab.

3. Click the Advanced button .

4. Open the Programs folder .

5. Open the Startup folder and delete the program that does not want to start automatically.

If you can't locate the program that is automatically loading, try searching for it in the System Registry.
Permanently disable TSR in Microsoft Windows 3.x

1. Open File Manager .

2. Locate and open the Startup folder .

3. Delete the program that does not want to start automatically from the Startup folder .

If_it_is_ not possible to locate the program loading automatically, try locating the program in autoexec.bat or
win.ini.

Permanently disable TSR in Autoexec.bat

Note : This section only applies to Windows 3.x, Windows 95, and Windows 98 users. If you are not sure which
version of Windows you are using, see the article: Identify the Windows version of the system for more
information. detail.

After following the instructions that are appropriate for the running operating system, if the program or TSR is
till automatically loaded every time the computer starts, it may be loading in autoexec.bat.

Permanently disable TSR in Win.ini

Note : This section only applies to Windows 3.x, Windows 95 and Windows 98.

If the program continues to load and you have checked the Startup folder and autoexec.bat, this program can also
load in the win.ini file. To check thisfile, follow the steps below.

1. Windows 3.x users click on the File menu and select Exit to go to MS-DOS prompt.
2. Windows 9x users click Start and Shutdown, then restart the computer in MS-DOS prompt.

3. When in the MS-DOS prompt, run the following two commands:



cd windows edit win.ini
4. Inthewin.ini file, look for the lines with the content:
LOAD= RUN=

5. Verify that these lines are only LOAD = or RUN =, no text after the equals sign. If not, this may be the
program is automatically loaded each time the computer starts.

6. To temporarily disable these lines, semicolons can be placed before them, as in the example below:
; RUN=

7. To savethefile, open the File menu (Alt + F) , select Exit and Save.

Permanently disable TSR in System Registry

Note : This section only applies to Windows 95, Windows 98, Windows ME, Windows 2000, Windows XP and
Windows Vista users. If you are unsure, check your version of Windows.

Windows 98 users should disable startup programs through System Configuration before making changes to the
System Registry.

If the program continues to load after restarting the computer and you have verified that the program does not
exist in the Startup directory, autoexec.bat or win.ini, the last place is System Registry. Before attempting to
modify or change the System Registry, please refer to the article: Understanding the Windows Registry to better
understand the potential risks when modifying the registry.

Once you've familiarized yourself with System Registry, open the registry key below to see which programs or
TSRs are loading in the System Registry.

[ HKEY_LOCAL_NMACHI NESOFTWAREM CROSOFTW NDOWSCURRENTVERSI ONRUN]
After locating the loading program, delete this program from the above key.

Important note : Do not delete any other files from any key.

Permanently disable TSR in System Configuration

Note : This section only applies to Windows 98 and Windows ME users. If unsure, please check the version of
Windows you are using first.

To disable startup programs via System Configuration, follow the instructions below:
1. Click Start> Programs> Accessories> System Tools> System Information .

2. In the System Infor mation window , click the Tools drop-down menu and select the System Configuration
utility .

3. Select the Startup tab and uncheck the programs that do not want to load automatically.



System Configuration utility and msconfig

Note : Theinformation below only appliesto Windows XP and Vista users.
To disable auto-load programs, follow the instructions below.
1. Pressthe Windows + R key to open the Run box . Then enter msconfig and press Enter .

2. In the System Configuration Utility window, click the Startup tab . Uncheck each boot task you do not want
to load. If you are not sure which startup program is causing the problem, try unchecking all items, then slowly
start checking each item until the source of the problem is identified. Restart the computer after checking each
item, allow the checked program to start when Windows boots and determine if the program is the source of the
problem.

Which TSRs can be safely disabled?

Unfortunately there is no specific list of TSRs that can be safely disabled on the computer. Although there are
some TSRs that are definitely not needed, the list depends on the version of Windows and the software installed
on the compuiter.

The best suggestion is, if you are not sure about the TSR appearing on your computer, look for information on
the Internet. Performing a search for the TSR file name, usualy with an .exe extension, will yield the best
results. See the top search results for information about TSR and determineif it can be safely disabled.

However, before researching TSRs on computers, users should run the software to remove all viruses and
malware. Some viruses and malware take advantage of TSR to infect computers. Removing these viruses and
malware will almost always remove the associated TSR from the computer. Once the computer has been cleaned
up, users can check the TSR and study which one should be disabled.

Good luck!
See more:

1. Turn off programs that start with the system on Windows 10
2. How to add a startup program with the system?
3. How to turn off Windows Update on Windows 10

Y ou finished reading the article "How to delete the TSR automatically starts when the computer isturned
on" edited by the TipsM ake team. We hope this article has provided you with many useful tech tips and tricks.
Y ou can search for similar articles on tips and guides. Thank you for reading and for following us regularly.
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