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How to delete junk files and clean your computer to
run faster

Regularly cleaning the computer as well as deleting junk files will help our PCs and Laptops run faster, and our
work progress will therefore be more productive, however, the main purpose is still to be able to use it quickly,
without experiencing inhibition when the machine is slow and especially keeping the machine lasting longer.

Computer waste is not as unhygienic as human waste, but in terms of discomfort, it is not inferior. Usually
computer junk is generated while we use it, such as temporary files, browser and application caches, redundant
shortcuts, corrupted registry errors, etc.

This article will help you delete junk files and clean your computer directly with tools available on Windows
without having to use third-party software. Please refer to the steps below to know how to do it and improve it.
Maximize computer performance.

1. Delete Windows.old, Windows update

For those who are using Windows 10, you will see that Windows.old and Windows update take up a lot of space
on your computer. Windows updates, we know are Windows update files that you downloaded but have not
installed or have installed.
And Windows.old is the backup when you update your Windows 10. If you delete this file, it will not come back
again. However, Windows.old in some cases is not useful at all and if you want, you can delete it.

Step 1: To delete Windows.old, Windows update, open StartMenu and type Disk Clean-up .
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Step 2: Here we choose drive C , where Windows.old, Windows update is located.



Step 3: Here is the familiar Disks Clean Up interface , but you will not see it until you click Clean up system
files .

Step 4: Here you will see Windows.old, Windows update if your computer is in the situation we mentioned
above. We just need to click and click OK to finish.



2. Set up automatic deletion of junk files

On Windows 10, there is a feature that allows your hard drive to delete some unnecessary files and other files
automatically after 30 days. Although after 30 days is too long and does not allow you to adjust the time, in case
you forget to delete the file, this is not a bad tool at all.

Step 1: Open StartMenu , type Storage and access the results found.



Step 2: Here you see the Storage Sense section , activate ON to enable automatic deletion of this junk file.



Step 3: Also, don't forget to regularly check the Temporary files or Other sections on drive C, these are the
sections that take up a lot of space on your hard drive.

1. Clean up junk files

For old computers and laptops, after a long time of use, the hard drive will be full because of the need to store
data. This is the reason why computer and laptop performance slows down over time. The process of searching
for files and programs takes longer.

To fix this situation, delete junk files and duplicate files on your computer to free up free hard drive space.
Usually, deleting music and photo files will significantly free up free space. Using Easy Duplicate Finder will
help you save a significant amount of time, clean up junk files as well as duplicate files on the system.

In addition, you can also use the tools and features built into the system to free up hard drive space by cleaning
files in the Recycle Bin, deleting temporary files and files that are no longer in use. again. 

On Windows 8, enter Disk Clean-up in the Search box from the Start menu. On the search results list, click
Clear Disk Space by deleting unecessary files . On Windows 7, go to Start => All Programs => Accessories



=> System Tools => Disk Cleanup .

Disk Cleanup will search for junk files on the system, calculate and tell you how much free space is freed after
deleting those junk files. Click View files to see the files that Disk Cleanup searches for. If there are files among
those files that you want to keep, just uncheck the boxes next to the files. Then click Clean up system files to
delete all junk files, unnecessary files on your Windows computer, including old Windows installation files,.
freeing up dozens of GB of free space.

2. Uninstall unnecessary programs that you no longer use



The next step is to uninstall programs that you no longer use. On Windows 8, enter Uninstall in the Search
Charm box, then on the search results list, click Uninstall programs to free up Disk Space . On Windows 7, go
to Start => Control Panel => Programs => Uninstall a program .

Here you will see a list of programs installed on your computer and the amount of free space each program takes
up. Scroll down the list, find and select the program you want to uninstall, then click Uninstall to uninstall. Note:
Only uninstall programs that you no longer use.

It is not always possible to completely remove traces of a program using built-in Windows utilities. In this case,
you need to seek the help of a third-party tool, Revo Uninstaller .

On Revo's interface, double click on the icon to delete the program from the system. Additionally, you can scan
and remove leftover files or Registry entries. 

3. Defragment the hard drive

After deleting files and uninstalling unnecessary programs on your computer, the next step is to compress the
remaining data so that your computer can access the data as quickly as possible.

In principle, more or less defragmenting or defragmenting your hard drive will significantly speed up your
computer and laptop. Suppose when data is stored on the hard drive, small packets of data will be stored in
random locations throughout the hard drive. The process of a Windows computer reading data to find out
information will take a lot of time. 

By defragmenting or compressing that data, Windows eliminates the gaps between data packets, moving these
packets into one location on the hard drive. Thus, the process of accessing the hard drive to read data will be
much faster. This will invisibly improve and speed up your computer and laptop significantly. 

The only thing to note is that if your computer uses an SSD, defragmentation will reduce the lifespan of the SSD
faster. 



To defragment the hard drive on Windows 7, click the Start button => All Programs => Accessories =>
System Tools => Disk Defragmenter .

Next click Defragment Now .

Windows 8 and Windows 10 computers or tablets will automatically defragment weekly by default on the
Optimise Drives interface . 

If you do not change any settings, you do not need to perform defragmentation. But if you are not sure and want
to check the status or want to manually defragment the hard drive, in the Search box , enter Defragment there.
On the search results list, click Defragment and optimize your drives .

A dialog box will appear on the screen containing a list of hard drives on your computer or laptop, the last time
the hard drive was defragmented, and how to defragment it. 

Defragmentation is only necessary if your hard drive is more than 10% fragmented. If you can't find the Current
status column , just find a specific hard drive that needs to be optimized and click Analyze . Then confirm
again. This will update the Current status column. 

4. Turn off programs that start with the system

To speed up your Windows computer, sometimes you don't necessarily need to uninstall a program , you just
need to turn off programs that start with the system. There are too many programs that automatically start with
the system, leading to a slow computer startup, which is understandable. Especially with older computers that
have been used for a long time, turning off programs that start with the system will speed up the boot process
significantly.

On Windows 7, enter msconfig in the Search box on the Start Menu, on the search results list, click to open the
System Configuration window . Here you click on the Startup tab and uncheck the programs that you no
longer want to start with the system, then click Apply => OK .



The free Soluto application analyzes your computer's boot time and will give you advice on which programs
that start up with the system. This utility is developed and improved based on System Configuration built into
Windows, allowing users to postpone some system startup items in case the computer does not respond or
crashes.

In addition, you can also prevent services from starting with the system to speed up your computer. However, it
should be noted that Windows requires a number of services to function properly. 

Enter services.msc into the Search Start Menu box to open the Services window . Here will display a list of
services that start with the system. Visit Black Viper to see which services can be delayed or disabled. 

Or to make it simpler, you can turn off programs that start with the system on Windows 8 or Windows 10
through Task Manager.

Open Task Manager: Press the Windows + Q key combination to open Charms on Windows 8, then enter
Task Manager in the Search box and press Enter to open Task Manager. 

Or alternatively, on the desktop, right-click on the Taskbar, or press the Windows + X key combination to open
the Start Menu, and select Task Manager. 

Finally, use the key combination Ctrl + Alt + Delete and select Task Manager.

On the Task Manager window, select the Startup tab . Here displays a list of programs that start with Windows,
along with the developer of each application and the degree to which applications affect startup performance
listed as low (low), high (high) or medium (medium).

Click on the program that you do not want to start with the system, right-click on it and select Disable . Or click
to select the program, then click Disable in the bottom right corner of the window. 



If you want to re-enable these programs, follow the same steps, right-click on the program and select Enable .
Or click to select the program, then click Enable in the bottom right corner of the window.

5. Clean and configure the desktop

This last trick helps you search for files and folders on your computer and laptop faster. Suppose if you need to
quickly find a file on your Windows 10 computer, just enter the file name in the Search box on the Start Menu
and you're done.

On Windows 7, Windows Search Assistant will be useful, in addition the Copernic Desktop Search Home
program indexes the entire hard drive so you can find files faster.

Documents should be stored in relevant folders, not on the desktop. Open Windows Explorer (on Windows 10
and Windows 8 also called File Explorer).

Access the Documents folder and create a new folder by right-clicking anywhere, selecting New => Folder . By
default, the new folder you just created is named New Folder, but you can rename the folder arbitrarily by right-
clicking on the folder icon, selecting Rename and giving it any name you want. Finally, just drag and drop the
related files into the folder.

Delete unused shortcuts on the desktop. This step does not mean uninstalling the program, but just deleting the
shortcut related to that program. Everything on the desktop will be much more 'open'. 

Next, right-click any empty space on the desktop, select View => Auto arrange icons to arrange the remaining
shortcuts on the desktop into a more compact grid.

In addition, you can also determine the content of a file from the name without having to open the file. And it
would be more useful if you set the date in the file name. If there are multiple similar files that need to be
renamed, simply copy and paste the general information into each renamed file.

To view general information about your folder: click the Change your view icon in the top right corner of the
folder, select Details . File size information, creation date and other information will be displayed next to the list
of your documents. Rearrange the list by date and file size by clicking on different tabs in the top corner of the
window.



Keywords are displayed every time you right-click the file and select Properties. In Word, access File =>
Properties , enter keywords in the Keywords box and click OK . For images, tag images with keywords, click
on the Tags box in the bottom corner of the Windows Explorer window to add.

6. Clean up the Temp folder on the system

Step 1: Delete all data in the Windows Temp folder. This is the folder containing all temporary files that the
computer saves during the process of installing and using the application.

First enter Start > Run , then type %temp%

After the Temp folder window displays, select all files (Ctrl-A) and press DELETE to delete.



Step 2: Delete Recent places history. This is where your computer saves recent activities, such as the last opened
folder, last opened music files, last opened images, etc.

To clear these activities, enter Start > Run , then type Recent places

After the Recent places folder window displays, press Ctrl-A and DELETE to delete all activities.



How to delete undeletable files

Step 3: Cache memory is created to speed up user operations. However, after a long period of storage, the cache
may retain unnecessary processes. So clear this memory to improve your computer's performance.

The cache is located in the Windows Prefetch folder. Type Start > Run , then type Prefetch

Computer trash cleaning software

After the Prefetch folder window appears, select all files inside and press DELETE.



How to clean up Windows 8 computer trash

Step 4: In addition to supporting the above methods, you can use Notepad + the code below to clean up trash on
your computer.

* Open Notepad on the computer.
Open the Run dialog box (Windows key + R) -> Type Notepad -> Enter

How to clean up your computer and make it run faster

- Copy the following code into Notepad then save it under any name with the extension .bat (eg donrac.bat)



Tips to clean up your computer to run faster

* Code snippet:
@echo off
color 0C echo Delete rac file for Windows
del /f /s /q %systemdrive%*.tmp
del /f /s /q %systemdrive%*._mp
del /f /s /q %systemdrive %*.log del /f /s /q %systemdrive%*.gid
del /f /s /q %systemdrive%*.chk
del /f /s /q %systemdrive%*.old del /f /s /q %systemdrive%recycled*.*
del /f /s /q %windir%*.bak
del /f /s /q %windir%prefetch*.* rd /s /q %windir%temp & md %windir%temp
del /f /q %userprofile%cookies*.*
del /f /q %userprofile%recent*.*
del /f /s /q "%userprofile%Local SettingsTemporary Internet Files*.*" del /f /s /q " %userprofile%Local
SettingsTemp*.*"
del /f /s /q "%userprofile%recent*.*"
echo The scan is complete. Thank you for following TipsMake!
pause
- Double click on the newly created .bat file and press any key from 0 - 9 or the letters A, B, CD, D, E, F
and wait for the program to run automatically for a moment.



How to clean up Windows 10 computer trash

For proficient computer users, deleting junk files and cleaning up the computer without using any software is
very welcome. On the other hand, you can also use CCleaner to remove unwanted software from your computer

If you are a Windows 10 user, you are probably familiar with your computer running sluggishly after a long time
of use. There are many causes for this situation on Windows 10, such as fragmented hard drives, faulty
applications, malfunctioning drivers. But the most common reason is probably still computer junk.

You finished reading the article "How to delete junk files and clean your computer to run faster" edited by
the TipsMake team. We hope this article has provided you with many useful tech tips and tricks. You can search
for similar articles on tips and guides. Thank you for reading and for following us regularly.
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