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How to Delete a L ocked File

This wikiHow teaches you how to delete alocked or otherwise restricted file on your Windows or Mac

computer. Y ou can use Safe Mode or an app called Process Explorer on Windows, while Mac users can either
use the Get Info window to unlock...

Method 1 of 4:

Using Safe Mode on Windows
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. Click the Windows logo in the bottom-left corner of the screen.
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Open Settings



. Click the gear-shaped icon in the lower-left side of the window.
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Update & Security. It's near the bottom of the Settings window.
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Click the[_Recovery Jtab. You'll find it on the left side of the window.



Windows.

Advanced start-up

Start up from a device or disc (such as a USB drive or DVD), change
Windows start-up settings or restore Windows from a system
image. This will restart your PC.

Restart now
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Click [ Restart now . It's near the middle of the page. Doing so will restart your computer into the
Advanced Options menu.

| Troubleshoot

Il || Reset your PC or see advanced options |

6. Turn off your PC

Click [ Troubleshoot ]. Thisoption is near the top of the screen.




Click [ Advanced options ). You'l find thisin the middle of the screen.

Start-up Settings

Change Windows' start-up behaviour

Go back to the
previous build

Click [ Startup settings J. It'son the right side of the screen.
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Click [ Restart ). Thisbutton is near the bottom of the screen.

Restart to change Windo

Enable low-resolution video mode
Enable debugging mode
Enable boot logging

Enable Safe Mode

Disable driver signature enforcement
Disable early-launch anti-malware protecti

Disable automatic restart on system failure
How

Select the " Enable Safe Mode" option. Press 4 or F4' on the"Startup Settings' window.



i Restarting

Wait for Windowsto finish restarting. If you use a password on your account, you'll need to select your
account and enter the password before proceeding.
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Find your file. Open Start



, open File Explorer
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, and locate the previously locked file.
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Deletethefile. Click the previously locked file, click the Home tab, and click Delete in the toolbar that

appesars.
1. Alternatively, you can click the file to select it and then pressthe Delete! key.
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Empty the Recycle Bin. Double-click the Recycle Bin icon on your desktop, then click the Manage tab
and click Empty Recycle Bin in the toolbar. Y our file should be deleted.
1. Onceyou've deleted your file, you can restart your computer to exit Safe Mode.
Method 2 of 4:

Using Process Explorer on Windows



o

Recycle Bin |prope

Open thelocked file. In order for the file to show up in Process Explorer later, you'll need to have the
locked file open.
1. Simply double-clicking the file will be enough to place it in the "Running" category of your
computer's Task Manager.

Open the Process Explorer page. Go to https://docs.microsoft.com/en-
us/sysinternal s'‘downl oads/process-explorer/ in your browser.[1]
1. Process Explorer isan official Microsoft app.
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05/16/2017 + ® 2 minutes to read » Contributors 1) @

3. By Mark Russinovich

Published: May 16, 2017
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Click [ Download Process Explorer ). Thislink is near the top of the page. Doing so will prompt the
Process Explorer ZIP folder to download onto your computer.

Process Explorer v16.21

05/16/2017 « (® 2 minutes to read « Contributors 1=} .

By Mark Russinovich

Published: May 16, 2017

Q' Download Process Explorer ;E{1.B ME)

Run now from Sﬁinternélé Live.

Introduction

4. Ever wondered which program has a particular file or directory open? N
Explorer shows you information about which handles and DLLs process:

The Process Explorer display consists of two sub-windows. Raaka): vind

Open the ZIP folder. In your computer's download folder (e.g., the desktop or the Downloads folder),
double-click the "ProcessExplorer.zip" folder to openit.
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Click the[ Extract ]tab. It'sat the top of the window. A toolbar will appear at the top of the window.
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Click [_Extract all _J. You'll find this option in the Extract toolbar. Clicking it prompts a new window to
open.



Click [__Extract . It'sin the bottom-right corner of the window. Thiswill install the Process Explorer app
and open itsinstallation folder.

1. By default, thiswill install the Process Explorer in its current download location.

2. If you want to change the installation location, first click Browse... and select a new folder.

Open Process Explorer. Double-click the procexp64 item in the folder if your computer uses a 64-hit
processor.
1. If your computer uses a 32-bit processor, you'll double-click procexp here instead.



Click when prompted. Thiswill open the Process Explorer main window.

Click [_File ). It'sin the top-left corner of the window. A drop-down menu will appear.



Click [__Show Details for All Processes . Thisoption isin the middle of the File drop-down menu.

Show Details for All Process

Click when prompted. The Process Explorer window will close and re-open.



Click [__Find J. It'satab at the top of the window.
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Click [__Find Handle or DLL... J. You'll find this option in the Find drop-down menu. A search box will
Pop up.




Enter thelocked file's name. Type the name of the locked file into the text box, then click Search to the
right of the text box.

16.

Sdlect the locked file. Click the name of the locked file in the search window.



Pocess  PID  Type  Name
System 4 Key HKLM\SYSTEM“\ControlS
System 4 File C:A\sbdend\SRmMetadata
System 4 File D:\$BExdend\$RmMetadata
System 4 File D:\$Edend\$RmMetadata
System 4 File CAsbdend\$RmMetadata
System 4 File ‘\Device\Harddisk Volume1
System 4 File \Device'\Harddisk Volume 1

Find the highlighted file name in Process Explorer. In the Process Explorer window (not the search
window), you should see the file's name highlighted near the bottom of the window.

Name

HKLM\SYSTEM
HKLM\SYSTEM\ControlSet001\Control\SESS
HKLM\SYSTEM\Control Set001
HKLM\SYSTEM\ControlSet001\Enum

HKU

HKLM\SYSTEM\DriverDatabase
HKLM\SYSTEM\Control Set001\Control\Notific
HKI_M\SYSTEM\Selup

3

HIU.M\SYSTEM\CnrmISetﬂm\Savmes
HKLM\SYSTEM\RNG
HKLM\SYSTEM\ControlSet001\Control\WMI\
HKLM\SYSTEM\ControlSet001\Comsaty ~ =
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Right-click the file name. A pop-up menu will appear.
1. If your mouse doesn't have aright-click button, click the right side of the mouse, or use two fingers
to click the mouse.
2. If your computer uses atrackpad instead of a mouse, use two fingers to tap the trackpad or press the
right side of the trackpad's mouse.
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Click [ Close Handle . It'sin theright-click pop-up menu. Doing so unlocks the file, making it possible
to delete thefile.
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Find your file. Open Start
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Deletethefile. Click the previously locked file, click the Home tab, and click Delete in the toolbar that

appesars.
1. Alternatively, you can click the file to select it and then pressthe Delete! key.
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Empty the Recycle Bin. Double-click the Recycle Bin icon on your desktop, then click the Manage tab
and click Empty Recycle Bin in the toolbar. Y our file should be deleted.

Method 3 of 4:

Using the Info Menu on Mac



Open Finder. It's the blue, face-like app icon in your Mac's Dock.
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Find thefile that you want to delete. On the left side of the Finder window, click the folder in which

your locked fileis stored.



Select thefile. Click the file that you want to delete.

Click [_File ). It'samenu item in the upper-left side of the screen. A drop-down menu will appear.



Get Info

Click [ Get Info ). Thisoption isin the File drop-down menu. Doing so opens awindow with the locked
file'sinformation.

Unlock the Get Info menu. If the lock icon in the bottom-right corner of the window is closed, click it,
then enter your administrator password.



Uncheck the" Locked" box. In the middle of the "Get Info" window, there will be a checkbox with the
word "Locked" next to it; uncheck this box to unlock thefile.

Closethe " Get Info" window. Click thered circle in the upper-left corner of the window.
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Movethefileto the Trash. Select thefile, click the Edit menu item at the top of the screen, and click
Moveto Trash. Thelocked file will be sent to the Trash.

Empty the Trash. Click and hold the Trash icon in your Mac's Dock, then click Empty Trash when
prompted. Doing so will delete anything in the Trash, including your locked file.

Method 4 of 4:

Using Terminal on Mac



Move to Trash

Movethelocked file to the Trash. Click the locked file to select it, then click the Edit menu item at the
top of the screen and click Moveto Trash in the resulting drop-down menu.
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Open Spotlight



. Click the magnifying glassicon in the top-right corner of the screen. A text box will appear.

s ‘ Q_ terminal
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Typein t er m nal . Thiswill search your computer for the Terminal app.



Q. terminal
TOP HIT
1 Terminal
'BOOKMARKS & HISTORY
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4 € 4 Ways to Create an ISO File - wiki...
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Click

>

Terminal. It'sablack box with awhite "> " icon on it. The Terminal app will open.



2:46 on ttvs000
t$ |sudo rm-Rf
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Typein theforce-empty command. Type sudo rm - R into Terminal, making sureto place a
space after "R". Don't hit 2Return’ just yet.[Z]

Open the Trash. Hold down Ctrl| while clicking the Trash icon to do so.



Find the locked file. If there are multiple filesin the Trash, find the locked one that you just del eted.
1. Ininstances where your Trash won't empty even though you've unlocked thefiles, select all filesin
the Trash by clicking one file and then pressing m;namh Al instead.

Copy thefileinto the Terminal window. Click and drag the locked file onto the Terminal window, then
release the mouse.
1. If you selected all of the filesin the Trash, clicking and dragging one file into Terminal will prompt
all of thefilesto copy into Terminal.



N\53:37 on ttyseee
tt$ sudo rm -R

Press ?.Bﬂ.ur.n] Once the files have copied into Terminal, pressing ?.Bﬂtum] will request permission to run
your force-delete command.

Typein your Administrator password. Thisis the password that you use to log into your Mac.
1. Youwon't see letters or characters appear as you type your password in Terminal.



Last login: Mon Aug~=—=2
: iMac:~
Password:[] eesesee Enter

3:37 on ttyseee
I sudn m -R

11.

Press ? Return' again. Doing so runs the force-delete command and empties the Trash. Y ou should no
longer have any locked or persistent filesin the Trash.

Y ou finished reading the article "How to Delete a L ocked File" edited by the TipsM ake team. We hope this
article has provided you with many useful tech tips and tricks. Y ou can search for similar articles on tips and
guides. Thank you for reading and for following us regularly.
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