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Createreportsin Access 2016 and use advanced
reporting options

In this article, we'll learn how to create, edit, and print reportsin Access 2016 and how to use advanced reporting
options.

The report helps you organize and present data in a user-friendly, printable format that helps share information
without having to grant database access. In this article, we'll learn how to create, edit, and print reportsin Access
2016 and how to use advanced reporting options.

Createreport in Access 2016

Access alows you to create reports from tables and query results.

Open the table or query the data you want to use to create the report:

| 7 Cookies Sold

Product Types - Products Table.Product Name - | Sales Unit.Product Name - |SumOfQuan -
Cookies Fudge Brownie One Dozen 7
Cookies Fudge Chocolate Single 6
Cookies Ginger Shortbread One Dozen 6
Cookies Chocolate Chip Single 5
Cookies Butterscotch Single 3
Cookies Fudge Brownie single 3
Cookies Cranberry Walnut One Dozen 3
Cookies White Chocolate Macademia Nut Half-Dozen 3
Cookies Snickerdoodle Single 3

Select Create > Reports group> Report :

Create External Data Database Tools ~ Q Tell me what you want to do...

m D ’ﬁ\ m .@-_ 1 D D\Form iz E‘ @ E‘ RReportWizard

. = Navigation ~
Table SharePoint Query Query Form Form Blank Report Report Blank

Design Lists ~  Wizard Design Design Form [E=More Forms © % Design Report

Tables Queries Forms Reports

Labels

Access will create a new report based on the object you choose. Part of the data may be on the other side of the
page, change the width of the columnsin the report so they are on one page.
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|3 cookies saia | @ Cookies Sold ",
Cookies Sold e
|2 e
Product Types [Products Table].[Product Name] [Sales Unit].[Prod.
| Cookies i |Buffer Pecan || One Dozen
Cookies |BufferPeccm ||S|'r1g|e
| Cookies |Bufferscotch ||Sing|e
Cookies |Choco|ofe Banana Walnut || One Dozen
| Cookies |Choco|0fe Banana Walnut ||Sing|e
Cookies |Choco|ofe Chip || Half-Dozen

Click Saveto save the report.

Deletefield in report:

Click any box in the field you want to delete, press Delete from the keyboard.

B Cookies Sold"’ Cookies Sold

Cookies Sold Wednesday.

............................................................................................................................................................

Product Types [Products Table].[Product Mame] [Sales Unit].[PFroduct Name]

| Cookies N | Butter Pecan || One Dozen

| Cookies b | Butter Pecan ||S|'ng|e

| Cookies | Butterscotch || Single

| Cookies | Chocolate Banana Walnut || One Dozen

| Cookies | Chocolate Banana Walnut ||5ing|e

| Cookies | Chocolate Chip || Half-Dozen

| Cookiss | Chocolate Chip || One Dozen

| Cookies | Chocolate Chip ||S|'ng|e

| Cookies | Cranberry Walnut || One Dozen

Then the field will be deleted. Make sure that the title of the field is also deleted, by selecting the title> press
Delete on the keyboard.



FH Cookies Sold | [l Cookies Sold

7] Cookies Sold (i TG T
EJ ............................................................................................................................................................
E Product Tpﬁ,: [Products Table].[Product Name] [Sales Unit].[Product Name]
Butter Pecan One Dozen
Butter Pecan Single
Butterscotfch Single
Chocolate Banana Walnut One Dozen
Chocolate Banana Walnut Single
Chocolate Chip Half-Dozen
Chocolate Chip One Dozen
Chocolate Chip Single
Cranberry Walnut COne Dozen

Print and savethereport in Print Preview

To print your report to Home > View > select Print Preview from the drop-down menu, the report will appear on
the printed page.
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If necessary, edit the page size, width, rotate the page with the commandsin Print Preview.



IVl © Tell me what you want to do...

'%'l IE @ Show Margins D = E‘%’

Print  Size Margins| | pint Data Only Portrait Landscape Columns Page
- - Setup
Print Page Size Page Layout

When finished, click Print, the print dialog box appears, adjust the printing options and click OK to print the
report.

File Print Preview Q Tell me w

Eﬂ [‘ﬁ Show Margins

Print% Size Margins " piint Data Only

w -

Print Page Size

Savereport

You can save the report in various formats such as Excel, text, PDF, HTML, etc. This is called exporting the
report file. Thanks to this feature, you can view and edit the report to better suit your needs.

To export areport in Access 2016 you do the following:

Inthe Home > View > Print Preview tab> find the Exter nal Data group> select the file type, click Moreto see
more options.

External Data Database Tools Q Tell me what you want to do...

’_‘J ‘;@ D ﬁ E@Access

o
g g g Word Merge

] ] BjTextfile
, @ 7 Text File r

SAXML File

s ODBC Saved Excel Text XML = PDF \Email
Database " ?More ™ Exports File  File or XPS 5 More ~
1k Export

Select the folder you want to save the report> enter the name> Publish :



[ Publish as PDF or XPS X

A 5 > ThisPC > Documents > v | Search Documents L
Organize ~ New folder x e
Academic Paper *  Name Date modified o
Lreated example Adobe 6/8/15 2:53 PM
Logos Blog 6/8/15 2:52 PM
Source completed projects 8/18/14 4:01 PM
. Custom Office Templates 10/7/15 3:32 PM
@ Microsoft Access
desktop backgrounds 7/23/14 8:46 AM
Z& OneDrive Encoded Files 8/13/14 1:59 PM
Final Cut Express Documents 8/23/13 8:43 AM
% This PC
Layouts 8/13/14 2:02 PM v
¥ Network ol | < >
FINGET BB akery Menu Report] v
Save as type: PDF &

Open file after publishing Optimize for: O Standard (publishing
online and printing)

® Minimum size
(publishing online)

Options...

A Hide Folders Tools ¥ Publish Cancel

Advanced reporting options

Report Wizard:
Thistool makesit easier to create reports from multiple tables and multiple queries.

In the Create tab> Reports group> Report Wizard :

Create External Data Database Tools Q Tell r

G D ’ﬁ\ ﬁ @ D FﬁFDrMWizard = \£| :| @ReportWizaS

i

) [E Mavigation ~
Table SharePoint Query Query Form  Form  Blank Report Report Blank Labels
Design  Lists~ Wizard Design Design  Form [E More Forms - Design Report
Tables Queries Forms Reports

The Report Wizard will appear.



Report Wizard

Which fields do you want an your report?

You can choose from more than one table or query.

Tables/Queries

able: Categories

S

Available Fields: Selected Fields:

Product Types
==

Cancel Finish

Select the field you want to appear in the report> click the right arrow> click Next :

Report Wizard

Which fields do you want on your report?

You can choose from more than one table or query.

Tables/Queries

: Categories
Table: Customers Fields:
Table: Menu Items

Table: Order Items

Table: Orders Table

Table: Orders: December

Table: Products Table

Table: Sales Unit

Query: Cakes & Pies Sold

Query: Cookies Sold W

Cancel Finish




Report Wizard

Tables/Queries

Table: Categories

Available Fields:

Which fields do you want an your report?

You can choose from more than one table or query.

S

Selected Fields:

D

-

Cancel Finish

Report Wizard

Tables/Queries

Table: Menu ITtems

Available Fields:

Which fields do you want on your report?

You can choose from more than one table or query.

ot

Selected Fields:

D

Product ID
Sales Unit ID

Product Types

Products Table.Product Mame
== | |Description

Sales Unit.Product Name
Price

Cancel Finish

Presentation of thereport:

If you only create a report from atable or a query, you can skip this step.

Select the option in the list to preview the report:




Report Wizard

How do you want to view your

data? Product Types

b 5 Products Table_Product Mame,
by Products Table Description

by Menu Items Sales Unit_Product Mame, Price
by Sales Unit

| Show me more information

Cancel < Back Finish

Click Next if satisfied with the presentation of the selected report. If not, you can customize group levels. Select
afield from the list, then press the right arrow to add it to the new level.

Report Wizard

Do you want to add any grouping
levels? Product Types

Products Table_Product Mame,

Products Table. Product N Description

roducts Table.Product Mar : :
Description Sales Unit_Product Mame, Price
Sales Unit. Product Mame k

Price

Priority

Cancel < Back Einish

If necessary, you can modify the order of the grouped fields, by selecting the field and clicking the nose on
Priority to move it up a step or down a step. Click Next when done.



Report Wizard

Do you want to add any grouping
levels? Product Types

Products Table_Product Mame,

Products Table,Praduct M Descripian

roducts Table.Product Mar -

Description = Sales Unit_Product Name
= Price

Priori

=

Sort datain reports:

Click the arrow as shown, select the name of the first field you want to sort, then select the Ascending or
Descending sort on the right.

Report Wizard
What sort order and summary information do you want for detail records?

You can sort records by up to four fields, in either
ascending or descending order.

| Descending
(None)
2 Ascending

Surmmary Options ...

Cancel < Back Finish

Y ou can arrange up to 4 fields, the sort will be applied one by one from top to bottom, the first sort will be main.
When satisfied with the layout you created, click Next .

Choose layout and report title

Click on the layout option to see what they look like, choose the one that's suitable for use.



Report Wizard

How would you like to lay out your report?

Layout Qrientation

C‘ Stepped @Eurh’ait

Hlock (C)Landscape
_uﬂme .........
A

Adjust the field width so all fields fit on
a page.

Cancel < Back Finish

Select vertical or horizontal rotation for the report.

Report Wizard

How would you like to lay out your report?

Layout Qrientation
() Stepped E
(®) Blodk Landscape

() Outline ’i—ﬁ:

Adjust the field width so all fields fit on
a page.

Cancel < Back Finish

When satisfied with the layout of your report, click Next , enter atitle for the report, select whether you want to
preview or modify its design, and then click Finish.



Report Wizard

What title do you want for your report?

Menu Repurﬂ

That's all the information the wizard needs to areate your
report.

Do you want to preview the report or modify the report’s
design?

@ Preview the report.
() Modify the report's design.

Cancel < Back

Report format

Like other applications in Office 2016, Access alows you to edit text colors, fonts, add images and more.

Edit the header and footer of the report:

To view and edit the header, footer of the report, select View > Design View . Headers and footers are placed in
the blank section below the Page Header and Page Footer:

{ﬂ Bakery Menu Report
LI T I O L L O e T T R T IR
# Report Header

# Page Header

 Categories_ID Header

# Products Table_|D Header

# Sales Unit_Product Mame Header
# Detail

Products Table_ProduciDescription

# Page Footer
# Report Footer

Depending on the design of the report, you will sometimes see no whitespace in the header and footer as shown.
If this is the case, you must change the header size and footer before adding anything to it. Just click on the
border and drag is okay.



# Page Header

& Categories_ID Header
& Products Table_|D Header

# 5ales Unit_Product Mame Header
& Detail

Prod j55|Prr::-ducts Table_ProductiDescription

# Report Footer

Add text to the header, footer:

Select the Design tab> Controls group> Label > drag the mouse in the white area to create a label, release the
mouse When the desired size is reached.

File Hame Create External Data Database Tools Design Arrange Farmat

f| I]Color;' '._ z Totals

Page Setup Q

o = =0 () @, [ =

View  Themes B Group i Hide Details ; Insert
B - & Sort Image ~
Views Themes Grouping & Totals Controls
Click on the newly created label to enter the text you need:
| Eﬂ Bakery Menu Reporl.
1 1 z 1 3 C 4 1 5 & 1 7

320 Glenwood Place, Raleigh, NC 27601 | songbirdbakery@email.com | 919-555- I6;4|I
& Categories_|D Header
# Products Table_ID Header
# Sales Unit_Product Mame Header
+# Detail

Adding datesto the header, footer:

In the Design > tab Header / Footer > Dateand Timegroup :

Design Arrange Format Page Setup Q Tell me what you want to do...

. Y7 @ E,E' Logo
1 Aa D & = . [ Title

o Ml —| Insert Page :
Image Mumbers F'G Date and Time

Controls Header / Footer



The dialog box appears, select the preferred date format, click OK .

Date and Time ? >

Indude Date
(® March 31, 2016

() 31-Mar-16
() 3/31/16
Indude Time
(@) 2:30:13 PM
() 2:30 PM

() 14:30

Sample:

March 31, 2015
2:30:13FPM

oK |:E | Cancel

In the Design > Header / Footer tab > Page Numbers:

Add page numbersto the header or footer:

Design Arrange Farmat Page Setup Q Tell me what you want to do...

. = ﬁlﬂlgLDga
1 Aa (7] &5, e - EhDTitle

-

Himbers E‘ Date and Time

Controls Header / Footer

The Page Numbers dialog box appears. Under Format > Page N to display only the number of the current page
or Page N of M to display the current page number and the total number of pages.

Under Position , select Top of Page or Bottom of Page so that the number of pages appears at the top or bottom
of the page.

Click on the drop-down arrow and select the alignment for the page number. When satisfied, click OK.



Page Numbers ? -

Format Ok h
I:'EI Page M o
I:::I Page M of M Cancel
Position

(®) Top of Page [Header]
(") Bottom of Page [Footer]

Alignment:
Center w

Show Mumber on First Page

Customizethelook of thereport:

Add alogo:

Go to Design > View > Layout View tab from the drop down list:



Home Create

—) A

View Themes Al Fonts -

Colors =

b

i - \ Report View

[ Iy,
CL Print Preview

I SLLNITIE

cts

N/ Design View
L |

In the Header / Footer group> L ogo

Layout View N

Design Arrange Farmat Page Setup Q Tell me what you want to do...
“ f=lLogo
A XYEH | I}
D = L - [ Title
] Aﬂ oD u 1 insert Page .
Image -~ MNumbers F.;'};,Date and Time
Controls Header / Footer

Select the logo you want to add> OK .



[E insert Picture X

T « Documents » bakery v & Search bakery o

Organize « Mew folder i 7 ]

s Quick access 2 & songbird_logo
[ Desktop »*
Documents o
* Downloads
| Pictures -

* SongBirp

PowerPoint 201¢

PP2016 '-B aKery

Presentaticns
@ Microsoft Access

¢@ OneDrive
v

File name: | songbird_loge V| Graphics Files w~

TOOI s v c an ce'

A small image of the logo will appear, drag to when the desired size is reached.

| E Bakery Menu Repnﬁ

= ek
)

., Menu

320 Glenwood Place, Raleigh, NC 27601 | songbird

If necessary, move the logo to the desired location by dragging and dropping.

| il Bakery Menu Report

-’ SongBirn”
s BAKET

Menu

320 Glenwood Place, Raleigh, NC 27601 | songbirdbakery@email.com
Change themereport:

Go to the Design tab> Themes > Themes group:




File Home Create External Data Database Tools Design Arrange Format Page Setup

i- _ I:l olors ~ .E otals ~ Praxy
:| Cal i Total %AO@D%EE[E'

View  Themes [A] Fonts - grgup i Hide Details
- - ort

Views Themes Grouping & Totals Controls

Select the theme you want:

File Home Create External Data Database Too

- @ I:lf:ﬂmf“s' '._ ETutaIsv E

View  Themes [Alronts~  G'OUP {5 Hide Details

- & Sort

Wiews In this Database

All All A4
EE{:I'ICH. EEEsEE

% :-1L. Dffice
1 m| Aa 1 Aa IlE| Aa E Aa 1
(]r [ 1 | ] 1] EEEEEE [ 1 111 || HENEEE
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T(ao |2k 2] |A )

Pri -
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== o EEEEEE
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[

L ﬂ|f| Browse for Themes...

B ErT'!_IE Save Current Theme...

[

I=:E| A en Feames [

The theme will be applied to the entire database:



| [l Bakery Menu Reporl.."-..__

'+ SongBirp
s BAKET'Y
Menu

320 Glenwood Place, Raleigh, NC 27601 | songbirdbakery@email.com | 919-555-1624

Cakes Fudge Marble The cake that dares ask the question: what if marble were
made of three types of chocolate? The answer... delicious.

Cakes French Vanilla Oo la lal Some people might say this cake has a certain je ne
sais guoi.. but we "sais quoi"-- lots of vanilla.

Cakes Strawberry Swirl A dizzying swirl of strawberries and créme. Hold on tight!

Cakes Cookies n' Cream Like dipping oreos and milk, but a cake, and not at all soggy.

Changethemefont:

In the Design tab> Themes group > Fonts:

File Home Create External Data Database Tools Design Arrange Format Page Setup

=] [Ae] Meoors+ B 3 ot .
jm S BBl Ag = [T 6, Ef) B

. N
Themes [ ronts»  Group 755 Hide Details <
- - & Sort

Views Themes Grouping & Totals Controls

Select the font you want:



File Home

View  Themes II' Fonts =

- -

Wiews Tl
All Access
searchi.
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W G G G Gh gh G

Forms

Customers

Customers |

oo fa] [
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kFMenu ltems
Cirder ltems

Cirder [tems
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Create External Data
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The font will be applied to the entire database:

= E nculﬂm' '._ ZTDtEﬂE

Database

Group i3 Hide Details

B Tt

Century Schoolbook

Century nchoolk.

Century Schoolboolk

Calibri-Cambria
Calibri

Cambria

Arial-Times Mew Roman
Arial

Tirnes Hew Bornan

Calibri Light-Constantia
Calilri Light
Constanta

(4]

Century Gothic-Palatino ...

Centuny Gothic
Falatino Linotype

Tur Cen MT-Rockwrell
Twy CTen MT
Rocloamell I}

Times Mewr Roman-Arial
Tiunes Mew Eoman
Arial

)



| E Bakery Menu Report

SongBirn
e BAKETY
Menu

320 Glenwood Place, Raleigh, NC 27601 | songbirdbakery@email com | 918-5

Cakes Fudge Marble The cake that dares ask the question: what if marble
were made of three types of chocolate? The
answer... delicious.

Cakes French Vanilla 0a la la! Some people might say this cake has a
certain je ne sais quoi... but we "sais quoi"- lots of
vanilla.

Cakes Strawberry Swirl A dizzying swirl of strawberries and créme. Hold on
tight!

Cakes Cookies n' Cream  Ljke dipping oreos and milk, but a cake, and not at
all soggy.

In the next lesson, we will learn how to edit the table in Access, select the data type for the field, limit the data,
the number of characters for the data entered in the field, and how to set the error message for the user. when
they enter the wrong data. Please read it.

Next article: Edit tablesin Access 2016
Previous article: Optionsto create data queries in Access 2016

Y ou finished reading the article "Create reportsin Access 2016 and use advanced reporting options" edited
by the TipsM ake team. We hope this article has provided you with many useful tech tips and tricks. Y ou can
search for similar articles on tips and guides. Thank you for reading and for following us regularly.
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